English | Deutsch
Home »

OpenVAS Change Request #34: Upgrade OpenVAS Server dependency from glib 2.6 to glib 2.8

Status: This change request has been obsoleted by change request #38 which asked for upgrade to glib 2.12.

Purpose

To allow using some newer functions of glib and to reduce code on the OpenVAS side.

References

(none)

Rationale

glib 2.8 offers a more comprehensive API. So far wishes include these functions: g_mkdir_with_parents().

Version 2.8 was introduced more than 3 years ago and thus is assumed to be generally available for all current operating systems.

Effects

The most critical effect is that OpenVAS may not be compatible with older operating systems. However, the conservative Debian GNU/Linux carries 2.12 for "old stable" version etch already.

Design and Implementation

The configure environments of openvas-libraries, openvas-libnasl and openvas-server need to be updated to require glib version 2.8.

History